Configure IP ACLs to Mitigate Attacks

作者:admin发表时间:2010-9-12 评论:0 点击 9,893+

Topology Diagram

Addressing Table

Device Interface IP Address Subnet Mask Default Gateway
R1 Fa0/1 192.168.1.1 255.255.255.0 N/A
S0/0/0 (DCE) 10.1.1.1 255.255.255.252 N/A
R2 S0/0/0 10.1.1.2 255.255.255.252 N/A
S0/0/1(DCE) 10.2.2.2 255.255.255.252 N/A
Lo0 192.168.2.1 255.255.255.0 N/A
R3 Fa0/1 192.168.3.1 255.255.255.0 N/A
S0/0/1 10.2.2.1 255.255.255.252 N/A
PC-A NIC 192.168.1.3 255.255.255.0 192.168.1.1
PC-C NIC 192.168.3.3 255.255.255.0 192.168.3.1

Objectives

Verify connectivity among devices before firewall configuration.

Use ACLs to ensure remote access to the routers is available only from management

station PC-C.

Configure ACLs on R1 and R3 to mitigate attacks.

Verify ACL functionality.

Introduction

Access to routers R1, R2, and R3 should only be permitted from PC-C, the management

station. PC-C is also used for connectivity testing to PC-A, a server providing DNS,

SMTP, FTP, and HTTPS services.

Standard operating procedure is to apply ACLs on edge routers to mitigate common threats

based on source and/or destination IP address. In this activity, you create ACLs on edge

routers R1 and R3 to achieve this goal. You then verify ACL functionality from internal

and external hosts.

The routers have been pre-configured with the following:

? Enable password: ciscoenpa55

? Password for console: ciscoconpa55

Username for VTY lines: SSHadmin

Password for VTY lines: ciscosshpa55

IP addressing Static routing

Task 1: Verify Basic Network Connectivity

Verify network connectivity prior to configuring the IP ACLs.

S tep 1. F ro m the P C -C c o mma nd pro mpt, ping the P C -A s e rv er.

S tep 2. F ro m the P C -C c o mma nd pro mpt, S S H to the r o u te r R 2 L o 0 inte

rfa c e. E x it the SS H se ss io n.

S tep 3. F ro m P C -C , o pen a web bro ws er to the P C -A s erv er (u s ing the IP a

ddre s s ) to dis pla y the web pa ge. C lo s e the bro ws er o n P C -C.

S tep 4. F ro m the P C -A s e rv er c o mma nd pro mpt, ping P C -C.

Task 2: Secure Access to Routers

S tep 1. Co nfigu re A CL 10 to blo c k a ll remo te a c c es s to the ro u ters ex c

ept fro m P C -C.

Use the access-list command to create a numbered IP ACL on R1, R2, and R3.

R1(config)# access-list 10 permit 192.168.3.3 0.0.0.0
R2(config)# access-list 10 permit 192.168.3.3 0.0.0.0
R3(config)# access-list 10 permit 192.168.3.3 0.0.0.0
S tep 2. A pply A C L 10 to ingr es s tra ffic o n the V T Y lines .

Use the access-class command to apply the access list to incoming traffic on the VTY

lines.

R1(config-line)# access-class 10 in
R2(config-line)# access-class 10 in
R3(config-line)# access-class 10 in
S tep 3. V er ify ex c lu s iv e a c c es s fr o m ma na gem ent s ta tio n P C -C.

SSH to 192.168.2.1 from PC-C (should be successful). SSH to 192.168.2.1 from PC-A

(should fail).

PC> ssh –l SSHadmin 192.168.2.1
Task 3: Create a Numbered IP ACL 100

On R3, block all packets containing the source IP address from the following pool of

addresses: 127.0.0.0/8, any RFC 1918 private addresses, and any IP multicast address.

S tep 1. C o nfigu re A C L 100 to blo c k a ll s pe c ified tr a ffic fro m the o u ts

ide netwo rk .

You should also block traffic sourced from your own internal address space if it is not

an RFC 1918 address (in this activity, your internal address space is part of the

private address space specified in RFC 1918).

Use the access-list command to create a numbered IP ACL.

R3(config)# access-list 100 deny ip 10.0.0.0 0.255.255.255 any
R3(config)# access-list 100 deny ip 172.16.0.0 0.15.255.255 any
R3(config)# access-list 100 deny ip 192.168.0.0 0.0.255.255 any
R3(config)# access-list 100 deny ip 127.0.0.0 0.255.255.255 any
R3(config)# access-list 100 deny ip 224.0.0.0 15.255.255.255 any
R3(config)# access-list 100 permit ip any any
S tep 2. A pply the A CL to inte rfa c e S e ria l 0/0/1.

Use the ip access-group command to apply the access list to incoming traffic on

interface Serial 0/0/1.

R3(config)# interface s0/0/1
R3(config-if)# ip access-group 100 in
S tep 3. C o nfirm tha t the s pe c ifie d tra ffic ente ring interfa c e S e ria l

0/0/1 is dro pped.

From the PC-C command prompt, ping the PC-A server. The ICMP echo replies are blocked by

the ACL since they are sourced from the 192.168.0.0/16 address space.

S tep 4. R emo v e the A C L fro m interfa c e S eria l 0/0/1.

Remove the ACL. Otherwise, all traffic from the outside network (being addressed with

private source IP

addresses) will be denied for the remainder of the PT activity.

Use the no ip access-group command to remove the access list from interface Serial

0/0/1.

R3(config)# interface s0/0/1
R3(config-if)# no ip access-group 100 in
Task 4: Create a Numbered IP ACL 110
Deny all outbound packets with source address outside the range of internal IP

addresses.

S tep 1. Co nfigu re A CL 110 to pe rmit o nly tra ffic fro m the ins ide netwo rk .

Use the access-list command to create a numbered IP ACL.

R3(config)# access-list 110 permit ip 192.168.3.0 0.0.0.255 any
S tep 2. A pply the A C L to inte rfa c e F 0/1.

Use the ip access-group command to apply the access list to incoming traffic on

interface F0/1.

R3(config)# interface fa0/1
R3(config-if)# ip access-group 110 in
Task 5: Create a Numbered IP ACL 120

Permit any outside host to access DNS, SMTP, and FTP services on server PC-A, deny any

outside host access to HTTPS services on PC-A, and permit PC-C to access R1 via SSH.

S tep 1. V er ify tha t P C -C c a n a c c e s s the P C -A v ia H T T P S u s ing the

web bro ws er.

Be sure to disable HTTP and enable HTTPS on server PC-A.

S tep 2. Co nfigu re A C L 120 to s pe c ific a lly pe rmit a nd den y the s pec ified

tra ffic .

Use the access-list command to create a numbered IP ACL.

R1(config)# access-list 120 permit udp any host 192.168.1.3 eq domain
R1(config)# access-list 120 permit tcp any host 192.168.1.3 eq smtp
R1(config)# access-list 120 permit tcp any host 192.168.1.3 eq ftp
R1(config)# access-list 120 deny tcp any host 192.168.1.3 eq 443
R1(config)# access-list 120 permit tcp host 192.168.3.3 host 10.1.1.1 eq 22
S tep 3. A pply the A C L to inte rfa c e S 0/0/0.

Use the ip access-group command to apply the access list to incoming traffic on

interface S0/0/0.

R1(config)# interface s0/0/0
R1(config-if)# ip access-group 120 in
S tep 4. V er ify tha t P C -C ca nno t a cces s P C -A v ia H T T P S u s ing the web

bro ws er .

Task 6: Modify An Existing ACL

Permit ICMP echo replies and destination unreachable messages from the outside network

(relative to R1);

deny all other incoming ICMP packets.

S tep 1. V er ify tha t P C -A c anno t s u c c es s fu lly ping the lo o pba c k inte

rfa c e o n R 2.

S tep 2. Ma k e a ny nec e s s a ry c ha nges to A C L 120 to pe rmit a nd den y the s

pec ified tra ffic .

Use the access-list command to create a numbered IP ACL.

R1(config)# access-list 120 permit icmp any any echo-reply
R1(config)# access-list 120 permit icmp any any unreachable
R1(config)# access-list 120 deny icmp any any
R1(config)# access-list 120 permit ip any any
S tep 3. V er ify tha t P C -A c a n s u c c es s fu lly ping the lo o pba c k interfa c

e o n R 2. S tep 4. C hec k res u lts .

Your completion percentage should be 100%. Click Check Results to see feedback and

verification of which required components have been completed.

顶一下 3 踩一下 0

你可能对以下内容感兴趣!

  1. Configure a Network for S...
  2. Configure and Verify a Si...
  3. Layer 2 VLAN Security
  4. Layer 2 Security
  5. Configure IOS Intrusion P...
  6. Configuring Context-Based...
  7. Configure AAA Authenticat...
  8. Configure Cisco Routers f...

发表回复

*

w_0002.gif w_0009.gif w_0007.gif w_0011.gif w_0005.gif w_0008.gif w_0010.gif w_0003.gif w_0012.gif w_0001.gif w_0006.gif